15.6" INITIA AMD - Working 99% | Page 2 | PCSPECIALIST

15.6" INITIA AMD - Working 99%

MicFli

New member
Hi - just saw this thread. I have an Initia 15.6 with Intel, and the touchpad wasn't recognised either. This is usually a kernel issue, but I tried kernels up to 5.10.1 and still no joy.

Eventually tracked it down to a problem with the i2c channel which is used by the touchpad. Look in dmesg for something like:

"platform i2c_designware.0: failed to claim resource 0: [mem 0x00000000-0x000001ff]"

which is the problem. You can add a kernel switch of pci=nocrs which seems to fix it (i.e. update /etc/default/boot to amend the grub command line to be something like

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pci=nocrs" then run sudo update-grub and reboot.

xinput should now show a touchpad:

FTCS1000:00 2808:0101 Touchpad id=11 [slave pointer (2)]

(see https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1884232)
 

spoo333

Member
Hello MICFLI,
thank you so much. I had already prepared the laptop for returning and then your solution turned up. Editing /etc/default/grub as you suggest does indeed cure the problem. The touchpad is recognised and I'm happy. Thanks a lot + have a lovely day (and all the others trying to help me too)
 

cyrMar

Member
Hi @bhunachicken
Could you pls share the module you found that enables keyboard backlight control ?
I just bought the exact same laptop but can't seem to find a suitable module...
Thx in advance !
 

bhunachicken

Active member
It's been a long while back since I installed the module, so I can't remember exactly where I got it.

But this might help?


It's definitely using /sys/devices/platform/tuxedo_keyboard, so this should be a good shout.
 

cyrMar

Member
Thx for the reply, I stumbled upon that link while looking a little harder & am gonna give it a try.
I plan on installing the whole tuxedo control center, did you try that as well ? any success stroy about that ?

EDIT: keyboard backlight driver is now installed & functionnal, thx a lot. Will keep u posted about TCC.
 
Last edited:

cyrMar

Member
Well, TCC works as well BUT it disables manual control of the fan (fn+1).
Uninstalled it as it didn't bring much value IMHO.
 

SteveAC

New member
All,

I got my Initia AMD yesterday and installed Mint 20.1 on it. Installed great straight out of the box. There's a handful of issues that I'm trying to iron out, if any one is able to help.

1. Brightness controls don't work (using Cinnamon desktop).

2. Keyboard is always lit (blue).

3. Suspend (sleep) results in a screen with a cursor in the top corner. Pressing a key brings up the lockscreen. mem_sleep reports that s2idle is set. ACPI says that S0, S4, and S5 are supported. I think I need S3 to be available for full sleep.

Output of inxi -F

System: Host: nova5 Kernel: 5.4.0-58-generic x86_64 bits: 64 Desktop: Cinnamon 4.6.7 Distro: Linux Mint 20 Ulyana
Machine: Type: Laptop System: PC Specialist product: NL5xRU v: N/A serial: <superuser/root required>
Mobo: CLEVO model: NL5XRU serial: <superuser/root required> UEFI: INSYDE v: 1.07.04TPCS date: 11/09/2020
Battery: ID-1: BAT0 charge: 36.9 Wh conditio processorm n: 38.3/36.2 Wh (106%)
CPU: Topology: 8-Core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP L2 cache: 4096 KiB
Speed: 1397 MHz min/max: 1400/2000 MHz Core speeds (MHz): 1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397
8: 1397
Graphics: Device-1: Advanced Micro Devices [AMD/ATI] Renoir driver: N/A
Display: x11 server: X.Org 1.20.8 driver: ati,fbdev unloaded: modesetting,radeon,vesa resolution: 1920x1080~77Hz
OpenGL: renderer: llvmpipe (LLVM 10.0.0 128 bits) v: 3.3 Mesa 20.0.8
Audio: Device-1: Advanced Micro Devices [AMD/ATI] driver: snd_hda_intel
Device-2: Advanced Micro Devices [AMD] Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A
Device-3: Advanced Micro Devices [AMD] Family 17h HD Audio driver: snd_hda_intel
Sound Server: ALSA v: k5.4.0-58-generic
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
IF: enp2s0 state: down mac: 80:fa:5b:8a:1f:a3
Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
IF: wlo1 state: up mac: b0:7d:64:12:10:06
Drives: Local Storage: total: 946.42 GiB used: 11.68 GiB (1.2%)
ID-1: /dev/sda vendor: Samsung model: SSD 870 QVO 1TB size: 931.51 GiB
ID-2: /dev/sdb type: USB vendor: SanDisk model: Cruzer Blade size: 14.91 GiB
Partition: ID-1: / size: 913.74 GiB used: 11.32 GiB (1.2%) fs: ext4 dev: /dev/dm-1
ID-2: /boot size: 704.5 MiB used: 204.8 MiB (29.1%) fs: ext4 dev: /dev/sda2
ID-3: swap-1 size: 976.0 MiB used: 0 KiB (0.0%) fs: swap dev: /dev/dm-2
Sensors: System Temperatures: cpu: 43.4 C mobo: N/A
Fan Speeds (RPM): N/A
Info: Processes: 296 Uptime: 54m Memory: 30.81 GiB used: 3.95 GiB (12.8%) Shell: bash inxi: 3.0.38
Hi Bhunachicken,

I have bought a very similar machine to you Initia AMD with 4700U. I am having the same problem that you had with the screen brightness control but even though I have the latest kernel there seems still to be a missing connection between control on Fn F8 and F9 and the Radeon graphics, the control works and the slider moves but nothing changes.It works fine in Windows 10. Any ideas? I also seem to have a problem with Bluetooth, my QC35 headphones refuse to connect, but I haven't investigated this yet. Otherwise I find this a great machine very happy with it.
 

bhunachicken

Active member
Hi SteveAC,

I'm still on the Cinnamon desktop, using the follow:

Linux nova5 5.8.0-55-generic #62~20.04.1-Ubuntu SMP Wed Jun 2 08:55:04 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux

NAME="Linux Mint"
VERSION="20 (Ulyana)"
ID=linuxmint
ID_LIKE=ubuntu
PRETTY_NAME="Linux Mint 20"
VERSION_ID="20"
HOME_URL="https://www.linuxmint.com/"
SUPPORT_URL="https://forums.linuxmint.com/"
BUG_REPORT_URL="http://linuxmint-troubleshooting-guide.readthedocs.io/en/latest/"
PRIVACY_POLICY_URL="https://www.linuxmint.com/"
VERSION_CODENAME=ulyana
UBUNTU_CODENAME=focal

That all works just great for me, including the F8 and F9 brightness keys. Unfortunately, I can't speak for Bluetooth headphones, as I only have Bluetooth on my phone (that the laptop can see when I perform a scan).

I remember when I first installed Mint some things didn't work, until installed all the latest updates. Maybe your new kernel has introduced a regression?
 

bhunachicken

Active member
(note: I've been unable to post the commands to run to get those outputs, as the forum software is blocking me from doing so..!)
 

bhunachicken

Active member
You can post any commands you like, just had to be in a code parameter from the toolbar

Afraid not. See the two CODE blocks I've tried to post.

error.png
 

StuAnderson326

New member
@bhunachicken - do you mind if I ask what the package you got to change the lighting was (and did you get a fix for this in the end?). I've installed OpenRGB but nothing showing up and I can't seem to find any vendor informationvia xinput -> udevadm :S
 

bhunachicken

Active member
I think you're going to have to Google that one, STUANDERSON326.

The kernel module is made by a competitor to PC Specialist, so linking to their website is probably against the forum terms and services.

I'll just say that the name of the firm starts with a T and is a type of suit one can wear :)
 
Top