All games suddenly unplayable (New Laptop) | PCSPECIALIST

All games suddenly unplayable (New Laptop)

LDUK

Master Poster
Hello everyone. I have had my laptop for about about 3 to 4 months now, and suddenly all games are Lagging really bad. The GPU says it's working 100%. Even when I turn down the setting and resolution. Everything else seems to work fine. I can't find anything in the internet that can help me.

These are my specs:
Chassis & Display
Ionico Series: 17.3" Matte QHD 165Hz sRGB 100% LED Widescreen (2560x1440)
Processor (CPU)
AMD Ryzen™ 9 Eight Core Processor 5900HX (3.3GHz, 4.6GHz Turbo)
Memory (RAM)
32GB Corsair 2933MHz SODIMM DDR4 (2 x 16GB)
Graphics Card
NVIDIA® GeForce® RTX 3070 - 8.0GB GDDR6 Video RAM - DirectX® 12.1
1st M.2 SSD Drive
1TB SAMSUNG 970 EVO PLUS M.2, PCIe NVMe (up to 3500MB/R, 3300MB/W)
Memory Card Reader
Integrated Micro-SD Memory Card Reader
AC Adaptor
1 x 230W AC Adaptor
Power Cable
1 x 1 Metre UK Power Cable (Kettle Lead)
Battery
Ionico Series Integrated 91WH Lithium Ion Battery
Thermal Paste
ARCTIC MX-4 EXTREME THERMAL CONDUCTIVITY COMPOUND
Sound Card
2 Channel High Definition Audio + MIC/Headphone Jack
Wireless Network Card
GIGABIT LAN & WIRELESS INTEL® Wi-Fi 6 AX200 (2.4 Gbps) + BT 5.0
USB/Thunderbolt Options
1 x USB 3.2 PORT (Type C) + 3 x USB 3.2 PORTS
Keyboard Language
IONICO 17 SERIES RGB BACKLIT UK KEYBOARD
Operating System
Windows 10 Home 64 Bit - inc. Single Licence [KUK-00001]

Any help would be appreciated!
 

SpyderTracks

Bingo Bango Orchestrator
Moderator
GPU should be 100% usage, that's expected and normal.

When you say it's lagging, what do you mean? Is that only in online gaming? Is it in a particular game?

Have you checked thermals?

Have you undervolted or overclocked at all?
 

Bhuna50

MOST VALUED CONTRIBUTOR
Lol. Unplugged and the power management likely kicking in reverting to using the AMD graphics not the dGPU. [emoji23][emoji23]

Been there done that [emoji3]


Sent from my iPhone using Tapatalk
 

LDUK

Master Poster
I can't believe I missed it. I was going crazy. Checking all my settings, checking the GPU drivers. The internet had nothing. So frustrated with myself that it was something as simple as that haha. And also pretty damn happy it was that simple 😅
I was also worried because my screen was yellowish, and that took me about 10 minutes before I realised I had the night time tint on. I'm losing the plot I swear 😂😂😂
 

Bhuna50

MOST VALUED CONTRIBUTOR
I was also worries because my screen was yellowish, and that took me about 10 minutes before I realised I had the night time tint on.

Didnt take me ten minutes, but been there done that as well LOL :D :D :D
 

DISCOSPARTA

Expert
I can't believe I missed it. I was going crazy. Checking all my settings, checking the GPU drivers. The internet had nothing. So frustrated with myself that it was something as simple as that haha. And also pretty damn happy it was that simple 😅
I was also worried because my screen was yellowish, and that took me about 10 minutes before I realised I had the night time tint on. I'm losing the plot I swear 😂😂😂

mate you need to go to bed (y)
 

LVAN

Member
I had the same thing too :ROFLMAO: could not find the "issue" lol.
But before I found out it was unplugged I already had reinstalled the chipset drivers, nvidia drivers and pulled out a few hairs :geek:
 
Top