Cosmos VII laptop alternating between charging and not charging

MKPhil

New member
My just-over-three year old Cosmos VII laptop has started alternating between charging and not charging - that is, the orange battery light is flashing and the charge symbol is coming on and off on the power icon in the system tray. It also goes in to low-power CPU mode (c. 1.5GHz instead of 3.2GHz). I've tested the output voltage on the charger and am getting a good 19.5 volts. If I take the battery out and just rely on the charger, the laptop dies after a few seconds.
Any clues what is wrong and what I can do to fix it?
 

SpyderTracks

We love you Ukraine
Moderator
My just-over-three year old Cosmos VII laptop has started alternating between charging and not charging - that is, the orange battery light is flashing and the charge symbol is coming on and off on the power icon in the system tray. It also goes in to low-power CPU mode (c. 1.5GHz instead of 3.2GHz). I've tested the output voltage on the charger and am getting a good 19.5 volts. If I take the battery out and just rely on the charger, the laptop dies after a few seconds.
Any clues what is wrong and what I can do to fix it?
A lot of new laptops actually require more power than just the charger alone can provide, so they actually draw battery power even when plugged in.

As such, they can often not work without a properly performing battery even when plugged in.

I would suggest installing HWMonitor and in there it has a battery wear reading at the bottom. What does that say?


1642633657397.png
 

MKPhil

New member
It shows a Battery wear level of 10% which I think is pretty good(?) - any other ideas or things to check?
 

SpyderTracks

We love you Ukraine
Moderator
It shows a Battery wear level of 10% which I think is pretty good(?) - any other ideas or things to check?
I would raise it with PCS, could be a disconnection somewhere in the charging circuit, perhaps a broken motherboard port.
 
Top