Linux Mint on a Lafité IV 15.6 And How to configure keyboard lighting

Tuxornot

Member
I did try and post a full review of this laptop but after four attempts that failed I gave up and moved to this section to post this in the hope it will help anyone who wishes to install Linux mint on this model of laptop.

I installed Linux Mint 20 Mate from a live USB with no issues, everything works as far as I know, including WiFi on the installed kernel 5.4, I did also test the install with kernel 5.8 without issues.

For anyone concerned about the bios being limited, Virtual-box works fine on my laptop and I run my usual array of virtual machines without problems.

I also cobbled together a guide to get the keyboard back lighting and track pad F1 key working, I faced some problems following other guides so ironed them out, basically you need to install Git and clone the tuxedo repo, make and install, the result should have the keyboard lighting working,the F1 track pad key working and these should be persistent across kernel updates.

The tuxedo keyboard is sadly lacking any indicator for caps lock so I have included instructions on adding an indicator to the panel for caps and number lock.

Note: all bold text is copy and pasted into terminal followed for the enter key.( the formatting here may look a little odd because I pasted it from my guide document I wrote up )

Install GIT :

sudo apt install git

CLONE THE TUXEDO REPOSITORY :

git clone https://github.com/tuxedocomputers/tuxedo-keyboard.git

CD INTO THE CLONED FOLDER IN HOME:

cd tuxedo-keyboard

Check THE RELEASE AND FOR UPDATES:

git checkout release

MAKE THE INSTALL:

make clean

sudo make dkmsinstall

sudo modprobe tuxedo_keyboard


Test by Press the Fn key and the number pad symbols

[Fn] / changes the colours. You get red, green, blue, yellow, purple, light blue, white, off

[Fn] * toggles the lights on and off

[Fn] - dims the lights

[Fn] + increases brightness

TO LOAD THE KEYBOARD MODULE INTO THE KERNEL AT BOOT:

CREATE AND OPEN THE KEYBOARD CONF FILE AND OPEN IT IN XED TEXT EDITOR:

sudo xed /etc/modprobe.d/tuxedo_keyboard.conf

Note that we write it's settings to a .conf file under /etc/modprobe.d named tuxedo_keyboard.conf.

THIS WORKING EXAMPLE SETS THE ENTIRE KEYBOARD TO RED AT 70 PERCENT BRIGHTNESS BY USING THE SETTINGS FOR LEFT, CENTER AND RIGHT KEYBOARD BACK-LIGHTING OPTIONS, SOME TUXEDO KEYBOARDS DO NOT SUPPORT MULTIPLE COLOUR SCHEMES.

PAST INTO THE OPEN TUXEDO,CONF FILE THE FOLLOWING LINE THEN SAVE AND CLOSE THE FILE:

options tuxedo-keyboard mode=0 brightness=70 color_left=0xFF0000 color_center=0xFF0000 color_right=0xFF0000

# The back light colour can be changed by changing the hex code for each colour, brightness can be changed in value, the example above sets it at 70 percent but I have mine set to 30 percent.

On reboot the keyboard should be controlled by the settings in the conf file, when the laptop is shut down and restarted the keyboard will cycle through its preset colours until Mint loads, at that point the keyboard is under the control of the conf file.

The track pad can now be disabled / enabled by using the F1 key.

Next part, caps lock and number lock indicators. Mint does have indicators already installed so we just need to activate the applete so it becomes persistent across reboots, open terminal and copy and paste this line then press the enter key to run the command:

gsettings set org.mate.peripherals-keyboard-xkb.general duplicate-leds true

The led indicator applete should be present in the panel near to the clock:


led indicator.png

Each indicator should turn red if the caps lock or number lock are active, scroll lock does not seem to work unfortunately.

--
Tuxornot.
 
Last edited:

SpyderTracks

We love you Ukraine
Moderator
Amazing directions, thank you so much for this, will add this to the Linux thread.

In fact, gonna sticky it!
 

Stephen M

MOST VALUED CONTRIBUTOR
Very helpful post, thanks. Being lazy I tend to just accept keyboard lights will not change and just ignore it but it is always good to see a solution to any problem.
 

Tuxornot

Member
Thank you for your comment, I hope by now you have control over your keyboard lighting !

I wanted to edit the my guide but keep seeing an 'ooops error',never mind.

The edit was to just show the color 0xFF0000 is RED.
 

ubuysa

The BSOD Doctor
Moderator
Thank you for your comment, I hope by now you have control over your keyboard lighting !

I wanted to edit the my guide but keep seeing an 'ooops error',never mind.

The edit was to just show the color 0xFF0000 is RED.
That's a known, and yet so far unresolved issue (not for the want of trying). If you have any smilies in your post delete them and try posting again. Almost any HTML markup (so italic text, bold, font change, etc.) seems to be able to trigger that message, but in my experience smilies seem to be the biggest offenders. :)

Edit: I just realised the post is in this thread (I'm half asleep this morning). There's a lot of HTML markup in there, the problem could be caused by almost any of it!
 

Tuxornot

Member
That's a known, and yet so far unresolved issue (not for the want of trying). If you have any smilies in your post delete them and try posting again. Almost any HTML markup (so italic text, bold, font change, etc.) seems to be able to trigger that message, but in my experience smilies seem to be the biggest offenders. :)

Edit: I just realised the post is in this thread (I'm half asleep this morning). There's a lot of HTML markup in there, the problem could be caused by almost any of it!

Thanks for explaining :)
I'll just leave the guide as it is other wise I will be in old age long before I work out what part is causing the error !
 

alukreis

New member
I've tried this with the INITIA 15.6 inch chassis model and it got the backlit keyboard working perfectly (after a restart) on Manjaro Linux (arch linux based) as in:
$ cat /etc/lsb-release
DISTRIB_ID=ManjaroLinux
DISTRIB_RELEASE=21.2.6
DISTRIB_CODENAME=Qonos
DISTRIB_DESCRIPTION="Manjaro Linux"

To do so, make sure you install base-devel and git first, then:

Install kernel headers for your kernel:

sudo pacman -S linux[version]-headers

e.g
sudo pacman -S linux515-headers

Install tuxedo-keyboard-git from the AUR:
cd [somewhere you like to build AUR packages]
git clone https://aur.archlinux.org/tuxedo-keyboard.git
cd tuxedo-keyboard
makepkg -s
sudo pacman -U tuxedo-keyboard[version].pkg.tar.zst

I tried to test with modprobe but it didn't seem to play ball, you should notice a new file in /etc/modules-load.d though and that will load the modules on boot as described above, so restart and good to go.
 

Tuxornot

Member

alukreis,​


Happy you got it working, Modprobe can sometimes be hit or miss with these backlit keyoards. Thank you for taking the time to post here and for the detailed account of the steps you did to get it working on Manjaro, I am sure this will hep other's in their quest :)
 
Top