New desktop Pc dead after 8 days | PCSPECIALIST

New desktop Pc dead after 8 days

So I have just RMA'd my computer back to PC specialist today after only 8 days due to it not powering up. When you click power all the PSU did was click once. I stripped the MB down to just the MB and CPU and even powered it up from the motherboard to no avail. How can it go from working perfectly one day to not even powering up the next. I suspect faulty PSU or MB but intrigued to hear people's thoughts?

Case CORSAIR 275R AIRFLOW TEMPERED GLASS GAMING CASE
Processor (CPU)Intel® Core™ i7 Eight Core Processor i7-10700K (3.8GHz) 16MB Cache
MotherboardASUS® TUF Z490-PLUS GAMING (LGA1200, USB 3.2, CrossFireX) - ARGB Ready
Memory (RAM)16GB Corsair VENGEANCE DDR4 3000MHz (2 x 8GB)
Graphics Card8GB NVIDIA GEFORCE RTX 2080 SUPER - HDMI, 3x DP GeForce - RTX VR Ready!
1st Storage Drive2TB SEAGATE BARRACUDA SATA-III 3.5" HDD, 6GB/s, 7200RPM, 256MB CACHE
1st M.2 SSD Drive512GB PCS PCIe M.2 SSD (2000 MB/R, 1100 MB/W)
Power SupplyCORSAIR 650W TXm SERIES™ SEMI-MODULAR 80 PLUS® GOLD, ULTRA QUIET
Power Cable1 x 1 Metre UK Power Cable (Kettle Lead)
Processor CoolingPCS FrostFlow 120 Series RGB High Performance Liquid Cooler
Thermal PasteSTANDARD THERMAL PASTE FOR SUFFICIENT COOLING
LED Lighting50cm RGB LED Strip
Sound CardONBOARD 6 CHANNEL (5.1) HIGH DEF AUDIO (AS STANDARD)
Wireless/Wired NetworkingWIRELESS INTEL® Wi-Fi 6 AX200 2,400Mbps/5GHz, 300Mbps/2.4GHz PCI-E CARD + BT 5.0
USB/Thunderbolt OptionsMIN. 2 x USB 3.0 & 2 x USB 2.0 PORTS @ BACK PANEL + MIN. 2 FRONT PORTS
Operating SystemWindows 10 Home 64 Bit - inc. Single Licence [KUK-00001]
Operating System LanguageUnited Kingdom - English Language
Windows Recovery MediaWindows 10 Multi-Language Recovery Image - Unlimited Downloads from Online Account
Office SoftwareFREE 30 Day Trial of Microsoft 365® (Operating System Required)
Anti-VirusBullGuard™ Internet Security - Free 90 Day License inc. Gamer Mode
BrowserMicrosoft® Edge (Windows 10 Only)
Warranty3 Year Silver Warranty (1 Year Collect & Return, 1 Year Parts, 3 Year Labour)
 

SpyderTracks

Huntsman
Moderator
Usually if the motherboard lights were on but it wouldn’t boot that would suggest the CPU wasn’t getting power, could have been a loose cpu cable on the motherboard or failed PSU.
 
So I turned off all RGB lights early on but couldn't see any MB specific lights when turned on so either TUF MB doesn't have a power light or the PSU is dead. I did try seating all cables again but no luck.
 
Top