**NEW** PC Specialist Website | PCSPECIALIST

**NEW** PC Specialist Website

Status
Not open for further replies.

Sling23

Banned
Hi Guys,

Just a message to say we are currently launching our new website. This should be fully up and running momentarily and we hope that you all enjoy the new look, any feedback or comments that you guys have on the new features please do let us know.

In addition to the New Website we also have a PCS Advertisement shown on the main page, this can be seen below.

[video=youtube_share;BbOI2Pf_A7A]https://youtu.be/BbOI2Pf_A7A[/video]

Thank you for all of your support

Sling23
 

Oussebon

Moderator
Moderator
Looks a lot more modern, seems smooth enough to navigate. Congratulations on the launch.

Not sure if this is an issue on my end, but on my desktop I snapped the window to half of my 1080p screen and got this when I scrolled to the side for the part of the web page that didn't fit:

new site 1.png
Happens on IE11, Edge, and a Chrome based browser, with cache etc cleared.

Seems to also slice the price bit off in some but not all configurators:
new site 2.png

Edit:
Also the Configure a Desktop page with Intel / AMD choice (https://www.pcspecialist.co.uk/custom-pc/) advertises Socket 1150 but I didn't know PCS still sold any of those (is there a 1150 Xeon configurator squirrelled away that I missed?), and the AMD bit doesn't mention Ryzen(!)

Apologies if this seems like a list of whinges, I just figured it was worth mentioning. :)
 
Last edited:

PCS Karl

Member
Looks a lot more modern, seems smooth enough to navigate. Congratulations on the launch.

Not sure if this is an issue on my end, but on my desktop I snapped the window to half of my 1080p screen and got this when I scrolled to the side for the part of the web page that didn't fit:

View attachment 10255
Happens on IE11, Edge, and a Chrome based browser, with cache etc cleared.

Seems to also slice the price bit off in some but not all configurators:
View attachment 10256

Edit:
Also the Configure a Desktop page with Intel / AMD choice (https://www.pcspecialist.co.uk/custom-pc/) advertises Socket 1150 but I didn't know PCS still sold any of those (is there a 1150 Xeon configurator squirrelled away that I missed?), and the AMD bit doesn't mention Ryzen(!)

Apologies if this seems like a list of whinges, I just figured it was worth mentioning. :)
Thanks for bringing these up. We are aware that the snapping isn't that fluid, but that should be fixed later this week when we release our responsive style changes.
 

ubuysa

Moderator
Moderator
Thanks for bringing these up. We are aware that the snapping isn't that fluid, but that should be fixed later this week when we release our responsive style changes.
Just so's you know, I get the same issue.

I really like the new website too, very modern looking. The video is excellent too, I never realised you were so big, I sort of imagined three guys in a shed somewhere! That's good to see, and I'm sure it will help prospective new customers to realise what a professional and trustworthy company you are. Ten out of ten and a gold star. Go to the top of the class! (Do they still give stars at school? It's been several decades since I was at school.....)

:clap:
 

Rakk

Moderator
Moderator
Just a quick note, there's no log out button once you're logged in (unless I've totally missed it)
On the 'My account' div, it has a down arrow suggesting there will be menu options available, but there currently aren't any options (at least on Chrome Version 58.0.3029.110) - that's kinda where I'd expect the 'Log out' option to be.
The code looks to be:
Code:
<div> <a style="color:#FFFFFF;" href="/customer-admin/">My Account<i class="fa fa-chevron-down" aria-hidden="true"></i></a> </div>
 

PCS

Administrator
Staff member
On the top navigation when you login to the customer account section there are 4 headers:

MY ACCOUNT
ORDER DETAILS
TECH SUPPORT
MY RETURNS

Each of these down drop down when you click them? Press Ctrl + F5 to check? Tested on all browsers.
 

Rakk

Moderator
Moderator
On the top navigation when you login to the customer account section there are 4 headers:

MY ACCOUNT
ORDER DETAILS
TECH SUPPORT
MY RETURNS

Each of these down drop down when you click them? Press Ctrl + F5 to check? Tested on all browsers.
Oh that's where it is, I would've expected it in the header :)

Edit: though clicking on said logout button gets a 404 error, oops (it does log you out)
 
Last edited:

A.J.Grant

Member
Great video, I didn't realize PCS Premises were so large. 4000 units a week... wow.

Congratulations on your new website.
 

Wozza63

Biblical Poster
We're looking into the issues now. Wozza, what's your beef with jQuery ;)
More or less everything can be done without the heavy jquery library these days, and its usually much quicker. Back in the day it offered so much that wasn't available anywhere else. A lot of the features $ offered can now be implemented in plain HTML/CSS animations being a good example.

Not to say that it is never required. It makes a lot of stuff easier, but there is probably a smaller and quicker library for what you want to do. Or a more feature rich one like Angular, React, Knockout etc.
 

Tony1044

Spamtastic
So... any chance making the forums accessible from my ee mobile phone?? Been grtting a 404 for a bit now if not one wifi or vpn.

Does the same from my laptop too if I tether.
 

Stephen M

Spamtastic
What sort of phone do you have, I am on EE and getting forum OK with mobile data and wifi. I am using a bq aquaris.
 

Tony1044

Spamtastic
What sort of phone do you have, I am on EE and getting forum OK with mobile data and wifi. I am using a bq aquaris.
S7 Edge

Happens with both the EE & BTU Firmware.

Oddly, as I say, it happens if I tether to the phone.

I can get straight in if I connect to a VPN first or over WiFi - it is purely in mobile data I have issues.
 

SpyderTracks

Huntsman
Moderator
S7 Edge

Happens with both the EE & BTU Firmware.

Oddly, as I say, it happens if I tether to the phone.

I can get straight in if I connect to a VPN first or over WiFi - it is purely in mobile data I have issues.
Can you manually set a dns in your mobile data settings?
 

ubuysa

Moderator
Moderator
On my phone (Samsung Galaxy S6 running Android 7) the right bit of the webpages are missing, it's as though there is a white band down the right side of the screen. The forums don't have this problem.
 
Last edited:

Rakk

Moderator
Moderator
On my phone (Samsung Galaxy S6 running Android 7) the right bit of the webpages are missing, it's as though there is a white band down the right side of the screen.
Same here, I lose everything to the right of the 'C' in Finance from the main menu at the top.
Using a OnePlus 3, Marshmallow (Android 6.01)
 
Status
Not open for further replies.
Top