No sound with Ubuntu 20 on Defiance laptop but hardware fine

ChaWar

New member
Greetings, I'm a newbie. I just set up my Defiance 15.6" with Nvidia RTX3080 GPU yesterday in a dual boot configuration (with Windows 11 and Ubuntu 20 each in a modest partition, and the rest of the single SSD as a data partition visible to them both). Generally everything worked fine first time, much to my relief -- including the touchpad and keyboard shortcuts to turn the brightness and volume up and down, things I thought might not work.

In Ubuntu, perhaps crucially I installed the Nvidia drivers for machine learning purposes. [Edit: no change if I revert to default Nouveau display driver in fact]

The one thing I cannot get to work is any audio output when running Ubuntu -- it's fine in Windows, so there is no hardware problem. I've Googled a lot of fixes and haven't found one that works yet.

Ubuntu thinks it is making sound, but nothing actually emerges. I do see the volume lights flicker up and down for it in Settings/Sound (and for the internal microphone when I talk, so that seems to be working).

I'll keep plugging away, but if anyone reading this immediately knows the answer already, I'd be very grateful to hear it. Obviously I'll post the solution if I find one, too.
 
Last edited:

Sandora

New member
It sounds like you're having the exact same issue as me! I received my Lafite 15.6" laptop yesterday and I'm running Linux Mint (Ubuntu based) as my primary OS. I've unfortunately experienced the exact same issue - literally everything works (WiFi, bluetooth, touchpad etc.) apart from the sound. I've tried every fix I can find but still no joy, the system simply won't recognise the built-in speakers or headphone jack. I've tried countless fixes and even updated to the latest kernels (which did fix a few other minor issues), but still no sound. I also tried a live boot of Manjaro (Arch based) to see whether it was a Ubuntu specific issue, but the outcome was the same.

I did however discover that sound works fine when connecting a USB peripheral so that's provided a partial workaround, meaning I can now use a USB headset or connect a headphone jack via a USB sound card. May be worth giving this a go? I find the system recognises USB audio devices immediately without issue. It's still very frustrating not to have the in-built speakers functional though.

I'm trying to see if I can find a solution from anyone on the Linux Mint forums and if I find anything that solves the problem, I will let you know. Fingers crossed one of us manages to come up with something!
 

SpyderTracks

We love you Ukraine
Moderator
Hiya both

Linux isn't my bag at all, so apologies if you've already tried this, but came across this thread:



Just in case somebody reached this question looking for a solution. The only native solution (no need to do something external) is provided by @Nate on this link https://askubuntu.com/a/37609/9598 which I reproduce partially here to give you a clue on how to fix this problem.

I [...] noticed that the ACLs weren't set in /dev/snd
sudo setfacl -m u:$USER:rw /dev/snd/*

and then do a reboot of your computer.

Running this command in a terminal will fix the issue.


If then you find it doesn't persist after reboot there's a further comment:

I don't know under which circumstances it is removed on reboot, but you can add this command to your crontab using sudo crontab -e then add @reboot setfacl -m u:$USER:rw /dev/snd/*. Maybe you are using a removable sound card? If so, just make sure your sound device is ready on start. Otherwise you may need to wait for a while sleep 60 (for 60 seconds delay), before the command runs.
 

ChaWar

New member
@Sandora -- good point about USB, thank you, I do have a USB headset I use for work so that's something. I guess Bluetooth devices should work, too.

@SpyderTracks -- thanks! That is one I tried unfortunately, no joy in my case.

[Both -- as a newbie I tried to tag you there -- your usernames came up in a kind of ToolTip and I clicked on them, but not sure it worked!]
 

ChaWar

New member
@Sandora -- a possible miracle for you. I tried adding 'Clevo' to my search terms and found this pretty quickly. I now have sound working in Ubuntu 20 both out loud from the speakers, and via headphones plugged into the 3.5mm jack!


As a wild guess, you might try adding a file named /etc/modprobe.d/sound-fixup.conf with the following content:

options snd-hda-intel model=clevo-p950


Then run update-initramfs -u as root to make sure the change will be effective in early boot also, then reboot and see if it results in an improvement.
 

Sandora

New member
No joy unfortunately. Whatever I do, it just won't recognise the speakers or jack. The hdajackretask tool only recognises the Intel Tiger Lake HDMI.
 
Top