Nvidia: how to white-list games and how to enable Nvidia GPU monitor: | PCSPECIALIST

Nvidia: how to white-list games and how to enable Nvidia GPU monitor:

CEUOTC

Enthusiast
As l see this crop up from time to time l have elected to start a thread to give a quick step by step guide:

White-Listing games to use the Dedicated Nvidia GPU:

1. Right click on desktop.
2. Select Nvidia Control panel.
3. Nvidia Control panel will open.
4. Select Manage 3D Settings.
5. You will see two tabs Global Settings and Program Settings.
6. Select Glabal and select High Performance NVIDIA Processor. (This effectively turns off Optimus using the NVIDIA GPU all the time).
7. Or Select Program Settings.
8. Select Add under 1.
9. Find the game you want to white list.
10. Click on Open.
11. Under 2. Select High Performance NVIDIA Processor if not already selected.
12. Select Apply.
13. Job done, time for tea, biscuts and medals.

And How to enable the Nvidia GPU monitor:

1. Select Nvidia Control Panel
2. Select Desktop drop down menu.
3. Select Display GPU activity icon in notification area.

Regards.

C.
 

Songe

New member
Just got my new Optimus IV last week, and I've noticed games are only running on the intel integrated graphics, rather than the nVidia GeForce GTX 765M.

In the nVidia control panel, the option under global settings, the option to change the preferred graphics processor is greyed out, so I can't make the GTX preferred.

Secondly, after trying to change the processor for each game individually under the program settings, for all steam games, the option is greyed out again.

I did some searching online and found others with the same problem, but everything I've seen hasn't helped.

I also tried downloading nVidia inspector and changing the driver options for each game for the 'Enable application for optimus' setting to 'SHIM_RENDERING_MODE_ENABLED'. But to my frustration, all the steam games insist on using the integrated graphics over my much more powerful GPU.

Please help

Thanks,

Sponge
 

CEUOTC

Enthusiast
Just got my new Optimus IV last week, and I've noticed games are only running on the intel integrated graphics, rather than the nVidia GeForce GTX 765M.

In the nVidia control panel, the option under global settings, the option to change the preferred graphics processor is greyed out, so I can't make the GTX preferred.

Secondly, after trying to change the processor for each game individually under the program settings, for all steam games, the option is greyed out again.

I did some searching online and found others with the same problem, but everything I've seen hasn't helped.

I also tried downloading nVidia inspector and changing the driver options for each game for the 'Enable application for optimus' setting to 'SHIM_RENDERING_MODE_ENABLED'. But to my frustration, all the steam games insist on using the integrated graphics over my much more powerful GPU.

Please help

Thanks,

Sponge
I take it you have downloaded and installed the latest Nvidia drivers? 320.49 WHQL

Should be straight forward to install, then try again, see also if the Nvidia experience helps (Should install automatically with the above driver)

Regards

C.
 

Songe

New member
Yes I have the latest drivers and I've tried re-installing them, re-installing them with a clean installation, 'optimising' my games, but none of that has caused my laptop to use the graphics card for these tasks

Thanks

Sponge
 

ubuysa

Moderator
Moderator
When you re-installed the NVIDIA drivers did you perform a clean install? There is a checkbox at the bottom of the driver installation dialog box called "clean install" and if you click that it removes all traces of previous drivers.

Boozad posted a very useful set of instructions in this post to perform the cleanest install of NVIDIA drivers that you can, it helped another forum member recently too.

Download whatever driver you want to use to your desktop. Next, go to Windows update and set it to 'check for updates but let me decide what to install' that will keep windows from automatically installing it's video driver. Next go to C:/Nvidia, open the folder and you should see a folder named Display driver. Inside that folder you should see a folder for every driver you have ever installed. They will be names 320.49 and such. Delete every one of those folders, but do not delete the display driver folder, just the ones inside. Next go to control panel > uninstall programs. Uninstall all of the Nvidia display programs, but this is important, uninstall the display driver last. Uninstall the Nvidia update, Phys X, 3D drivers (few people use them), Nvidia HDMI, and the Nvidia update (it does not work anyway). Last uninstall the display driver. You will be told to reboot, do so. When you log back on, windows will install a display adaptor, that is OK. Open your driver that you have downloaded from Nvidia, agree to terms, do not select express install, select custom install. Make sure the 'clean install' check box is selected and uncheck everything except the display driver and PhysX, then install. You will have to reboot after that. That will be the cleanest install you can get, and you will not have the HDMI driver to conflict with the Realtek drivers, but should have all the drivers you need. You can then set windows update back to whatever you like.


All credit is due to Boozad for this, he deserves the rep if it works for you. :)
 

Ed23

Active member
Sorry not sure if this is relevant anymore, but I had the same issue, reinstalling drivers helped (but it had to done in certain order for it to work and was time consuming).

The other and a faster way is to download a program called Nvidia Inspector, (instructions here), with this you can easily enable dedicated gpu option for any (even the ones with greyed out option) program, also changed advanced settings (msaa, fxaa etc).

Hope this helps.
 

tom_gr7

Life Serving
I wish there was a way to just switch off the integrated Intel graphics, e.g. in BIOS.
Whilst that would be useful, wouldn't it lead to you needing to have the laptop constantly plugged in? - Unless you do anyway ofc. My Optimus eats the battery when running on the 650m.
 

rapiddescent

Bronze Level Poster
indeed. i did some tests and running the GTX-760M all the time isn't feasible. The core temperature rises from 44'C to 90'C as well and the fans come on which isn't great in an office environment. See Linux section for more detail, but I ended up running the Bumblebee to solve my optimus problems.
 

alx

New member
Hello!
I've got my optimus laptop with 850m and when trying to play Archeage it uses the integrated GPU.
At the nvidia control panel the choosing for nvidia high performance GPU is greyed out and stayed greyed out even when I tried to use nvidia inspector?
Any other ways to solve this?
 

Doggie52

Member
For you, alx, and others having issues with this, you can try the following that worked for me:

1) Go to C:\Program Files\NVIDIA Corporation\Control Panel Client or otherwise find the folder where your nvcplui.exe executable lies.

2) Right-click the nvcplui.exe executable, go to Properties, Compatibility and check the Run this program as an administrator. Close the window.

3) Now open the NVIDIA Control Panel, go to Manage 3D settings, click on the Program settings tab, select whatever program you want to use the external GPU for from the dropdown list and select High-performance NVIDIA processor under the second drop-down list.

4) If the above steps don't solve the problem, make sure you are also running the desired application as an administrator.
 
Top