Old SSD not working

Klindog

Member
Hi, this has totally nothing to do with equipment I've bought from PC Specialist but thought I'd try my luck. I have an old ssd (Samsung T5 External SSD 1TB), but it isn't showing up on my pc to transfer things into it. I've tried formatting it on my PS5, which worked, but doesn't recognise it on my pc. I've been into the device management and computer management to try and find an option to format or go into the disk but nothing appears. It does show up under Device manager/ Disk Drives but I can only see its properties and can't access it. I've looked online for advice but nothing has worked so far. Any last minute ideas before I throw it away?

Thanks.
 
A PS5-formatted SSD is not usable on a PC, so that's one reason, but as long as you can see the drive (even if you can't access anything on it) in Windows, then disk management (start typing 'disk management' into the Cortana search bar and it should appear) should let you re-initialise/format it to make it usable in Windows (usually NTFS).

* or diskpart if you're comfortable with command line
 

Scott

Behold The Ford Mondeo
Moderator
When you were in Computer Management, you should have seen the option for Disk Management in there. That would have the drives showing and allow you to partition & format it.
 

Klindog

Member
1644257591410.png

Cheers for the replies, so when I right click on disk 2 it comes up with the options Convert to dynamic disk/ Convert to MBR disk. And when I right click on the unallocated section it comes up with the option to create a New simple volume. Does that help me?

Thanks
 
View attachment 32258
Cheers for the replies, so when I right click on disk 2 it comes up with the options Convert to dynamic disk/ Convert to MBR disk. And when I right click on the unallocated section it comes up with the option to create a New simple volume. Does that help me?

Thanks
I can't read anything on that picture, but if it's the empty bottom one in the list, then it's a 'new simple volume' that you need.
 
Top