PC not shutting down

IRLRobinS

VALUED CONTRIBUTOR
I know many people post about their PC shutting down when they don't want or expect to, but in the last day or so I've experienced the opposite: when I want to shutdown the PC, it won't!

In Windows 10, I got to start->power->shutdown and the shutdown process begins as normal. Eventually the display goes black, displays the no signal message, but the fans, aio and gpu all remain on and lit up. I have to hold down the case power button to shut it down fully.

I've done the usual step of googling the issue and disabling Fast Startup is often presented as a solution, but disabling it had no effect. SFC /scannow was also run. nothing found. Windows updates are all installed, including optional.

Anyone got any ideas?
 

SpyderTracks

We love you Ukraine
Moderator
Hiya

This does happen, it's usually related to a process that's refusing to stop correctly on shutdown.

One thing to check first, open event viewer and go to the application logs.

Find your last shutdown, and just before it check for event ID 10001 from source winsrv

If it is a rogue process, it will be labelled something like "the following process attempted to veto the shutdown: ProcessName"
 

IRLRobinS

VALUED CONTRIBUTOR
Yep, entries with that event id, all for steam. But they're there since I got the PC, and this problem has only surfaced in the last day or so. And I actually changed steam so it didn't launch at startup and the issue is still occurring.
 

IRLRobinS

VALUED CONTRIBUTOR
Holding shift when clicking shutdown allows the pc to shutdown fully, so there’s a workaround. But would still like to understand the cause
 

Bhuna50

MOST VALUED CONTRIBUTOR
are there any Windows updates outstanding?

Also does it do it when you have used the PC but not opened Steam at all? If it is only Steam files listed on what SpyderTracks asked then perhaps there are some erroneous Steam files still opening despite your setting so a complete uninstall / reinstall of Steam might be worthwhile.
 

SpyderTracks

We love you Ukraine
Moderator
Holding shift when clicking shutdown allows the pc to shutdown fully, so there’s a workaround. But would still like to understand the cause
That does suggest it's related to hibernate.

I would disable hibernation anyway on any PC personally.
 

IRLRobinS

VALUED CONTRIBUTOR
are there any Windows updates outstanding?

Also does it do it when you have used the PC but not opened Steam at all? If it is only Steam files listed on what SpyderTracks asked then perhaps there are some erroneous Steam files still opening despite your setting so a complete uninstall / reinstall of Steam might be worthwhile.
Updates all installed. And issue occurs even if I didn't launch steam, or if steam is started on startup but no games played.
 

IRLRobinS

VALUED CONTRIBUTOR
I think Steam is a red herring. From day 1 when I installed Steam and had it set to run on Windows startup, whenever I shutdown I would see a message similar to this on screen, showing Steam:
1643363831622.png


But after a few secs, Steam would close itself and shutdown would complete as expected. So my understanding of this is that Steam was just slow in shutting itself down and was holding up Windows in completing its shutdown activities until Steam exited.

And now, with Steam no longer running on Windows startup, I still have the shutdown issue.

So I'm not convinced Steam is the root cause.
 

Scott

Behold The Ford Mondeo
Moderator
I believe what's meant by the above is, what does the event viewer show for shutting down now that you have taken Steam out of the equation?

It seems to me that the signal from the OS to the motherboard/BIOS isn't triggering the actual "off" signal, rather than the shutting down procedure. If that's the case it's likely related to the power settings/config in the BIOS.

Is it an ASUS motherboard?

Could you try 2 things quickly.......

Open up a command prompt, type in Shutdown /s /t 0

If that doesn't work

Boot back into windows, open up the command prompt, type in the above command again but don't hit enter. Remove the monitor cable from the back of the PC and then hit enter.

See if that works.
 

IRLRobinS

VALUED CONTRIBUTOR
I believe what's meant by the above is, what does the event viewer show for shutting down now that you have taken Steam out of the equation?
Event viewer has no entries for Winsrv after Steam is set not to launch on startup.

Is it an ASUS motherboard?
It is, Strix B550-F.

Open up a command prompt, type in Shutdown /s /t 0
I presume this is an equivalent to the Shift+Shutdown action? Worked the first time I did it, but not on subsequent goes.

Boot back into windows, open up the command prompt, type in the above command again but don't hit enter. Remove the monitor cable from the back of the PC and then hit enter.
This did not work either.
 

Scott

Behold The Ford Mondeo
Moderator
I presume this is an equivalent to the Shift+Shutdown action? Worked the first time I did it, but not on subsequent goes.


This did not work either.

No, it's just a standard shutdown through command line. I just wanted to be sure it was done exactly the same way on both occasions. Strange that it worked once and not another time.

Being an ASUS motherboard I've heard of a number of power config gremlins over the years. They are pretty trick & pretty high end, but being so adds complexity to the BIOS and can often cause little niggles (such as you are finding).

I was clutching at straws by making sure there wasn't an issue with the cable, as I've heard this before also. Removing the cable before shutting down rules that out.

Nothing in the event viewer rules out the shutdown procedure of windows itself.

Some of these may be intel system related only so apologies if they don't relate, I don't have any way of knowing what options there are:

Download the latest AMD Chipset drivers from the AMD website & install.
In the BIOS go to advanced -> apm -> ErP/EuP settings and set the settings to S5 state
In the BIOS disable USB Legacy
Turn off Fast Startup, Hibernate & Sleep options in the Windows power management.

If all else fails its time to try a full on reset of the BIOS. Turn off the PC, unplug from the wall. Allow all energy to dissipate (all LED's off, etc), I tend to just leave it alone for a couple of minutes before returning. Either use the clear CMOS jumper or remove the CMOS battery. Give it 20 seconds then replace/reverse the battery/jumper.

Fire it up and see how it goes. If it works, go back into your BIOS and re-enable XMP etc. Do one or 2 things at a time so that you can keep track until you are happy with the BIOS configuration. If it ever stops working you can at least narrow down what caused it.

After that... I think it's back to PCS as that's probably about the limit to which I would check things.
 

IRLRobinS

VALUED CONTRIBUTOR
To close the loop on this, I tried Scott's steps above, but was still experiencing the same issue with shutdown. A few days later, I added a new Firecuda 530 SSD to the build, and did a clean install of Windows 10, and the issue is no longer present. So that would indicate it was a software issue rather than a hardware issue imo.

With my latest install, I installed all Windows updates expect this one:
2022-01 Cumulative Update Preview for Windows 10 Version 21H2 for x64-based Systems (KB5009596)

I recalled that I installed this preview update just a day or 2 before I observed the issue, so it could well be this update has a bug in relation to shutdown, so I've held back from installing this optional update for now.

So no definitive root cause, but at least it's no longer reoccurring. Thanks to everyone who contributed ideas.
 
Top