PC won't turn on first time

acrx93

New member
Just opened my brand new PCSpecialist PC. When I press the on button for the first time, all the lights and fans turn on for a few seconds then turn off and then back on again repeatedly

This is my brand new PC out of the box and I haven't even done first time set up yet.

I have already checked all the cables are in correctly and I have tried replacing the power cable aswell. But it still won't turn on properly

Specs are below - I've also included a link below to a video which shows what is going on (Password for video: 1234)


Case
CORSAIR iCUE 5000X RGB MID TOWER GAMING CASE
Processor (CPU)
Intel®️ Core™️ i7 12-Core Processor i7-12700K (3.6GHz) 25MB Cache
Motherboard
ASUS®️ ROG STRIX Z690-A GAMING WIFI D4 (LGA1700, USB 3.2, PCIe 5.0) - ARGB Ready
Memory (RAM)
64GB Corsair VENGEANCE RGB PRO DDR4 3200MHz (4 x 16GB)
Graphics Card
12GB NVIDIA GEFORCE RTX 3080 Ti - HDMI, DP, LHR
Graphics Card Support Bracket
PCS ARGB GRAPHICS CARD SUPPORT BRACKET
1st M.2 SSD Drive
1TB SAMSUNG 980 PRO M.2, PCIe NVMe (up to 7000MB/R, 5000MB/W)
1st M.2 SSD Drive
4TB SEAGATE FIRECUDA 530 GEN 4 PCIe NVMe (up to 7300MB/R, 6900MB/W)
Power Supply
CORSAIR 1200W HXi SERIES™️ MODULAR 80 PLUS®️ PLATINUM
Power Cable
1 x 1.5 Metre UK Power Cable (Kettle Lead)
Processor Cooling
CORSAIR iCUE H150i ELITE LCD Display RGB CPU Cooler
Thermal Paste
STANDARD THERMAL PASTE FOR SUFFICIENT COOLING
LED Lighting
2x 50cm RGB LED Strip
Sound Card
ONBOARD 6 CHANNEL (5.1) HIGH DEF AUDIO (AS STANDARD)
Network Card
10/100/1000 GIGABIT LAN PORT
USB/Thunderbolt Options
MIN. 2 x USB 3.0 & 2 x USB 2.0 PORTS @ BACK PANEL + MIN. 2 FRONT PORTS
Operating System
Windows 11 Home 64 Bit - inc. Single Licence
 
Last edited:

SpyderTracks

We love you Ukraine
Moderator
When I press the on button, all the lights and fans turn on for a few seconds then turn off and then back on again repeatedly

This is my brand new PC out of the box and I haven't even done first time set up yet.

I have already checked all the cables are in correctly and I have tried replacing the power cable aswell. But it still won't turn on properly
Hiya

Is this a pcspecialist pc? Could you post your full specs from the order page?
 

SpyderTracks

We love you Ukraine
Moderator
Yeah it is a PC Specialist PC - I've amended my original post with the specs and managed to upload a video aswell
Thanks

Ok, so motherboards getting power ok.

It's a really good spec, there's nothing wrong at all with the power requirements or anything.

The CPU 6 pin to the motherboard may not be fully inserted, could have come loose when removing the foam. It's usually in the top left of the motherboard, can be quite fiddly to reach. Take it out and fully insert it again.

Obviously make sure the PSU is switch off before you do this.
 

Scott

Behold The Ford Mondeo
Moderator
Give the RAM a gentle press also, as well as any cables/plugs that you see... just while the side is off anyway.

Excellent system :)
 
Top