Control Centre 3.0 problem - apps won't load | PCSPECIALIST

Control Centre 3.0 problem - apps won't load

Hi. Anybody else have loading issues with Control Centre v3.0 using a Vortex IX laptop? Worked fine initially and I had consistent access to the various apps (Power settings, Hotkeys, fan speed, LCD keyboard). Then suddenly, only the power setting app would open. Other apps show the "spinny wheel" briefly as if they are about to load, but then don't. I assumed that a major Win 10 update had broken something vital so I uninstalled the pre-loaded Control Centre software and driver fully before re-installing - no joy. I then went to the Clevo downloads section and got the latest zipfile software and driver - v1.24 I think - removed, reinstalled, but still nada.

I have tried running the apps as Administrator, repairing/resetting the individual apps but still only the power setting app loads properly. Funnily enough when I hover over the graphics overclock or the fan settings icons in the control centre desktop, they have each other's summary. Its almost like a firmware mismatch situation but I can't see any Bios/Uefi settings which would override or restrict these hardware/software settings. Anyone have experience of this and can advise? Thanks in advance.
 
Top