RGB on RTX 4090 flashes orange twice intermittently and cannot be adjusted

VoiceOfKit

New member
Hi all.

I have recently purchased a Creator Ultra PC from PCSpecialist, and the RTX 4090 it came with has two entirely (seemingly) cosmetic problems:

- The SPECTRA colour adjustment tool of ZOTAC FireStorm does not work - the button to select it within the application does not work (have tried numerous reinstallations.) This isn't really a major issue for me, and I suspect it's to do with how this is an OEM Zotac 4090, not one of the ones their software is designed for. However:
- The RGB lights on the graphics card flash orange twice on boot before returning to the default rainbow. After a few hours of playing games, this happens again roughly every 20 seconds, with seemingly no impact on performance, until the machine is restarted.

I have tried:

- Reseating the graphics card
- Changing where the PSU cable is connected into the PSU itself
- Downloading and running ZOTAC's firmware flash tools (none work)

Would it be possible to get answers on what I can do here? The machine is otherwise impeccable.
 

Attachments

  • 2023-08-12 (2).png
    2023-08-12 (2).png
    44.1 KB · Views: 81
  • Screenshot 2023-08-12 170236.png
    Screenshot 2023-08-12 170236.png
    160.5 KB · Views: 77
  • Screenshot 2023-08-12 170507.png
    Screenshot 2023-08-12 170507.png
    201.7 KB · Views: 81

SpyderTracks

We love you Ukraine
Hi all.

I have recently purchased a Creator Ultra PC from PCSpecialist, and the RTX 4090 it came with has two entirely (seemingly) cosmetic problems:

- The SPECTRA colour adjustment tool of ZOTAC FireStorm does not work - the button to select it within the application does not work (have tried numerous reinstallations.) This isn't really a major issue for me, and I suspect it's to do with how this is an OEM Zotac 4090, not one of the ones their software is designed for. However:
- The RGB lights on the graphics card flash orange twice on boot before returning to the default rainbow. After a few hours of playing games, this happens again roughly every 20 seconds, with seemingly no impact on performance, until the machine is restarted.

I have tried:

- Reseating the graphics card
- Changing where the PSU cable is connected into the PSU itself
- Downloading and running ZOTAC's firmware flash tools (none work)

Would it be possible to get answers on what I can do here? The machine is otherwise impeccable.
Firstly, make sure you're on the latest VBIOS

Secondly, make sure no other RGB controllers are running when testing it as they can lock the RGB of the board out.

This is a very common issue with Zotac cards

There's a solution posted for the same card on Reddit but it is just a google drive link, so it may be worth reaching out to Zotac for an official link (which may be the same)

"Okay, I found a fix!!It was posted by Zotac itself, and my card's RGB works now!!!

Just download the program and run it, super simple, it resets your card's RGB controller and now everything is working just fine again!!!

A few things, it seems the executable is not signed, so you WILL get an OS warning about running it, I overrode this warning, don't want to RMA my card, and it worked for me, but you do this at your own risk, YMMV, I really hope this fix works for everyone having this issue, but for obvious reasons, I can't take any responsibility for how this may affect your system, again, TRY THIS AT YOUR OWN RISK, AND GOOD LUCK!"

Source:
 

VoiceOfKit

New member
Firstly, make sure you're on the latest VBIOS

Secondly, make sure no other RGB controllers are running when testing it as they can lock the RGB of the board out.

This is a very common issue with Zotac cards

There's a solution posted for the same card on Reddit but it is just a google drive link, so it may be worth reaching out to Zotac for an official link (which may be the same)

"Okay, I found a fix!!It was posted by Zotac itself, and my card's RGB works now!!!

Just download the program and run it, super simple, it resets your card's RGB controller and now everything is working just fine again!!!

A few things, it seems the executable is not signed, so you WILL get an OS warning about running it, I overrode this warning, don't want to RMA my card, and it worked for me, but you do this at your own risk, YMMV, I really hope this fix works for everyone having this issue, but for obvious reasons, I can't take any responsibility for how this may affect your system, again, TRY THIS AT YOUR OWN RISK, AND GOOD LUCK!"

Source:
Hi there,

Thanks so much for your response.

There are no other RGB controllers running - I uninstalled Corsair iCUE and do not use any other software of this type.
Any attempt to update the VBIOS and the fix you linked unfortunately also does not work.
 

SpyderTracks

We love you Ukraine
Hi there,

Thanks so much for your response.

There are no other RGB controllers running - I uninstalled Corsair iCUE and do not use any other software of this type.
Any attempt to update the VBIOS and the fix you linked unfortunately also does not work.
Best to contact Zotac or PCS
 

letchy

Member
Did u manage to find a fix ? I've also just bought a 4090 zotac from pc specialist and I'm having the same problems
 

PCS_Chris

Moderator
Staff member
Moderator
Hi guys,

Please try this version of the Zotac Firestorm utility:

Firestorm V4.0.0.017E01

We discovered an issue with the RGB control of the SI only models of the Zotac GPU's. They have given us this special version of the program which would be able to detect these GPU's properly. Please let me know if it works for you both.

I should mention that Zotac said they would be implementing this fix into release V4.0.0.018E so I would recommend trying this version of the software first.

Chris
 

letchy

Member
still starts to flash orange, and doesn't let me control the rgb. restart still fixes it for about an hour
 

SpyderTracks

We love you Ukraine
still starts to flash orange, and doesn't let me control the rgb. restart still fixes it for about an hour
I would wait for @PCS_Chris to confirm as I'm not certain if the Firestorm is the same across any of the 4090 models, I can't see why not, but can't be certain

But there is a newer version labelled as V4.0.0.019E which may be worth a try.

ZOTAC GAMING GeForce RTX 4090 AMP Extreme AIRO
FireStorm_V4.0.0.019E (GeForce 40)
OS: Windows 11 64-bit, Windows 10 64-bit
DOWNLOAD
 
Top