Recoil II RTX In Exploration | Page 2 | PCSPECIALIST

Recoil II RTX In Exploration

roakes

Bronze Level Poster
Which driver have you installed? notebook driver or standard driver?
I don't think I manually downloaded and installed from Nvidia.com. I installed the drivers from PCS which I think included Geforce Experience and then just let that do the updating.
 

bana845

Member
I think I found the problem.
Perhaps the CPU was used as a PhysX processor instead of the GPU.
In the nvidia control panel, I set the RTX 2070 as the default PhysX processor.
Now the performances have clearly increased.
The results in the tests are in line with your results.
max FPS and average FPS have increased significantly.
Also the temperature of the GPU, rightly reached 65-70° (good temps however).
Anyway at some point come in power limitation e reliability voltage (obviously).

Below basemark benchmark with default afterburner curve:

Basemark Vulkan.jpg

Basemark DX12.jpg


Below basemark benchmark with changed afterburner curve:

Basemark Vulkan with  changed curve.jpg

Basemark DX12 with changed curve.jpg

Max power and max voltage are locked in vbios.
the mobile gpu is limited to 115W but with a small % margin.
From what I understand GPU Boost 4.0 pushes GPU frequencies as max as possible until the power limit or voltage limit/reliability have reached (temperatures permitting).
I saw the Power GPU reach 124W, 2100mhz with voltage that go up over 1V
temperatures never above 71° with low fans speed.
need to download again 3dmark and rerun.
 
Last edited:

roakes

Bronze Level Poster
Excellent work, I think you've solved it! Now you're getting higher scores than me, might be time to switch roles and see if there's something I need to set to squeeze a little extra out of mine ;)

Over the weekend I set a new voltage curve, I now use 1695mhz at 768 mV, if you want to try to get a little extra performance over 1545/725, although that still results in scores lower than yours now :D
 
Last edited:

bana845

Member
This time I did not manually change the curve by blocking mhz/volt.
I used OC Scanner (button in top left corner in MSI afterburner curve) so that it make an auto scan with 4 cycle, settings the best values for maximize performance.
I have not set any limits. Limitations i think are vbios power limit and voltage limit. Boost 4.0 reach maximum value as possible (as with default curve) but with a diferent mhz/volt ratio.
Now i'm tryingto understand if power limit and voltage limit/reliability produce throttling ... but i think no. It simply limit.
However, you also try to set the GPU in the nvidia control panel and to remove the automatic selection of the PhysX processor. I'm curious.
 

roakes

Bronze Level Poster
I set it manually now myself, it made no difference to performance.

The OC scanner will be setting an overclock rather than an undervolt, that explains your performance boost, I'm happy to overclock desktop GPUs but hesitate to do it on a laptop GPU due to the thermal constraints, so I'll stick with the undervolt :)
 

bana845

Member
Yes, It's just a test, with the default or with the undervolt the performances are more than enough.
With all default (no overclock) Boosts reached all limits anyway: power, volt and mhz. temp never above 70°.
I think overclock is a borderline concept with Boost 4.0.
Anyway, yes , in my case OC scanner change the ration mhz/voltage, make starting with high frequencies with same voltage, but limits are locked in vbios.
 

MattS2K

Member
Hi,

apologies for jumping on the thread but I think its relevant - I too have recently bought the same laptop and am getting disappointing benchmark results so wanted to try setting the RTX 2070 as the default PhysX processor to see if it worked for me. However, I don't have the NVIDIA control panel installed.

Searching for it only returns web results - which suggest updating the driver but I have updated to the latest drivers using GeForce experience and still don't have the control panel. Another post suggested it might be hidden and could be forced to make an appearance by right clicking an applications icon, selecting 'Run with graphics processor' and then clicking 'Change default graphics processor'. When I do this on my old laptop it does indeed launch the NVIDIA control panel but on my new one it does nothing.

Does anyone know how I can install this please!?
 

bana845

Member
Hi MattS2K,

I had same problem with the pcspecialists default installation or drivers downloaded from support page.
Anyway I did a new installation from scratch of all software.

As first step search for executabe here : C:\Program Files\NVIDIA Corporation\Control Panel Client\nvcplui.exe
If there isn't then I suggest you to remove your current nvidia driver (and all nvidia software), beginning from windows control panel-> remove program.
follow this guide: https://www.wikihow.com/Uninstall-Nvidia-Drivers
Then download last version of "RTX 2070 notebook" driver from nvidia and install it.
Personally i do not use geforce experience, but if you want you can reinstall it along with new installation.
Last driver with a clean installation should work.
Remember to select "clean install" option when installing.
 
Last edited:

roc

Bronze Level Poster
Think I found the problem.
PhysX is enabled in Nvidia control panel but on the gpu-Z physx checkbox is not checked.
Do you know how to fix it?
 

bana845

Member
uhm...sound strange.
gpu-z should recognize that rtx 2070 support physx.
try to refresh gpu-z with refresh button on top right corner.
You also should have NVIDIA PhysX Software entry in control panel -> programs
 

roc

Bronze Level Poster
I have al things set up correctly in nvidia control panel an I doble check the physx option and it’s set up correctly. I’m sure it’s an issue between cpu and gpu drivers but i don’t know how to fix it:(
 

bana845

Member
I 've more options because i'm connected to an external display.
If i use the laptop display i've same options.
Anyway it seems to be correct from what i see.
You have selected rtx 2070 as physx processor and you should be ok.
you can try to select also the check box, anyway, with your same configuration my GPU-Z recognize the physX feature.
What's your problem now?
 
Top